base.txt 1.3 KB
Newer Older
1 2 3 4 5 6 7 8
# Wheel 0.25+ needed to install certain packages on CPython 3.5+
# like Pillow and psycopg2
# See http://bitly.com/wheel-building-fails-CPython-35
# Verified bug on Python 3.5.1
wheel==0.30.0


# LTS Django
9
django~=2.1
10 11

# Configuration
12
django-environ==0.4.5
13 14

# Models
15
django-model-utils==3.1.2
16 17

# Images
18
Pillow==5.4.1
19 20

# Password storage
21
argon2-cffi==19.1.0
22 23 24

# For user registration, either via email or social
# Well-built with regular release cycles!
25
django-allauth==0.37.0
26 27 28

# On Windows, you must download/install psycopg2 manually
# from http://www.lfd.uci.edu/~gohlke/pythonlibs/#psycopg
29
psycopg2-binary~=2.7
30 31 32 33 34

# Unicode slugification
awesome-slugify==1.6.5

# Time zones support
35
pytz==2018.9
36 37

# Redis support
38 39
django-redis==4.10.0
redis>=3.0.1
40

41 42
django-filter==2.0.0
djangorestframework==3.9.1
43
django-rest-auth[with_social]==0.9.3
44
django-cors-headers==1.2.0
Bruno Martin's avatar
Bruno Martin committed
45 46


47
django-cities-light~=3.5
Bruno Martin's avatar
Bruno Martin committed
48
django-autocomplete-light==3.2.10
49 50 51

# libs needed by django-rest-framework api auto documentations
coreapi==2.3.3
52 53 54
coreapi-cli==1.0.9
pygments==2.3.1
markdown==3.0.1
55
django-crispy-forms==1.7.2
56

57
django-autoslug==1.9.4
Bruno Martin's avatar
Bruno Martin committed
58 59 60 61 62 63

# The above requiriments are for the django-courses-legacy package
django-braces==1.13.0
django-localflavor==2.1

# django-oauth-toolkit
64 65 66 67 68 69 70

django-compressor==2.2

# Sass compliler
django-libsass==0.7

pinax-webanalytics==4.0.2